Skip to content

microsoft/EnterpriseMCP

Folders and files

NameName
Last commit message
Last commit date

Latest commit

 

History

28 Commits
 
 
 
 
 
 
 
 
 
 
 
 

Microsoft MCP Server for Enterprise

Microsoft MCP Server for Enterprise Logo

Overview

Built on the open Model Context Protocol, the public preview of Microsoft MCP Server for Enterprise lets AI agents access Microsoft Entra data by converting natural language queries into Microsoft Graph API calls. This MCP server empowers developers and IT Administrators to integrate the management of organizational data into AI-powered workflows.

Full Documentation: Overview of Microsoft MCP Server for Enterprise

MCP Server Provisioning (execute once per tenant)

To get started with the Microsoft MCP Server for Enterprise, you need to:

  1. Provision the MCP Server. In Graph Explorer, send:
    POST https://graph.microsoft.com/v1.0/servicePrincipals
    Body: { "appId": "e8c77dc2-69b3-43f4-bc51-3213c9d915b4" }

  2. Register a new app, representing the MCP Client. Set the appropriate Redirect URI (also called Reply URL) depending on the client. For example:
    Claude Desktop needs https://claude.ai/api/mcp/auth_callback,
    ChatGPT generates a different one for each client using the format: https://chatgpt.com/connector/oauth/<random_chars>,
    Microsoft Foundry generates a different Redirect URI for each connector using the format: https://<random_chars>.<region>.azurecontainerapps.io/rest/oauth2-credential/callback

  3. Associate the MCP permissions (MCP.<Microsoft_Graph_Scope>) between the MCP Server and the MCP Client
    Associate MCP Client Permissions

Info Table

Property Value Notes
MCP Endpoint https://mcp.svc.cloud.microsoft/enterprise Configure in your agent or mcp.json
MCP Server App Id e8c77dc2-69b3-43f4-bc51-3213c9d915b4 Used for provisioning and telemetry
MCP Client App Id < The one you registered in your tenant > Required to configure your agent
Token URL https://login.microsoftonline.com/organizations/oauth2/v2.0/token Required in some agents config
Token endpoint auth method client_secret_post Required in some agents config
Auth URL https://login.microsoftonline.com/organizations/oauth2/v2.0/authorize Required in some agents config
Refresh URL https://login.microsoftonline.com/organizations/oauth2/v2.0/token Required in some agents config
Scopes api://e8c77dc2-69b3-43f4-bc51-3213c9d915b4/.default Required in some agents config

Tools

This MCP Server is atypical: instead of exposing a separate tool per Microsoft Graph operation, it applies Retrieval-Augmented Generation (RAG) and few-shot prompting to generate complete Microsoft Graph queries.
It exposes only three tools to implement a reliable and grounded workflow:

  1. microsoft_graph_suggest_queries: Finds relevant Microsoft Graph API calls based on user intent.
  2. microsoft_graph_get: Executes read-only Microsoft Graph API calls, respecting User roles and MCP Client scopes.
  3. microsoft_graph_list_properties: Retrieves properties of specific Microsoft Graph entities to help the AI model

Current scope and capabilities

For Public Preview, our focus is to support read-only enterprise IT scenarios focused on Microsoft Entra identity and directory operations (user, group, application, device management, and administrative actions).

In particular, the MCP Server can handle queries related to:

  1. Security posture: authentication methods/strengths, Conditional Access, Security Defaults.
  2. Privileged access: Who has which directory roles, how assigned (direct vs group), and PIM status.
  3. Application risk: Which Apps / Service Principals exist, who owns them, what permissions/SSO they use, and which are ownerless or external.
  4. Access governance: Who has access to what (users, groups, packages); review decisions, automate joiner/mover/leaver.
  5. Device readiness: Managed/compliant status, join state, OS/version distribution, and stale or inactive devices.
  6. Provenance and investigation: End‑to‑end telemetry (sign‑in, audit, provisioning, network), health alerts, and SLA/availability.
  7. Optimize spending & hygiene: License counts/usage, unused or stale apps/groups, domain configuration and contacts.

Supported Clients and Configurations

The Microsoft MCP Server for Enterprise is designed to work with any MCP-compatible client supporting the latest standard.

⚠️ Notes:

  • Dynamic Client Registration (DCR) is not supported, but we are working to support OAuth Client ID Metadata Documents (CIMD) in a future release.
  • ChatGPT and Claude, and GitHub Copilot CLI are supported only with custom client Id: you need to register your own MCP Client application in your tenant and assign the required MCP.* scopes and configure the redirect URIs accordingly.

Visual Studio Code / GitHub Copilot CLI

To associate the permissions between the MCP Server and Visual Studio Code or GitHub Copilot CLI, you need to execute the following steps:

  1. Install Microsoft.Entra.Beta PowerShell module (version 1.0.13 or later, requires PowerShell 7):

    Install-Module Microsoft.Entra.Beta -Force -AllowClobber
  2. Connect Microsoft Entra ID to your tenant:

    Connect-Entra -Scopes 'Application.ReadWrite.All', 'DelegatedPermissionGrant.ReadWrite.All'
  3. Grant all permissions to Visual Studio Code / GitHub Copilot CLI:

    Grant-EntraBetaMCPServerPermission -ApplicationName VisualStudioCode
  4. For VSCode, click Install Microsoft MCP Server for Enterprise to launch the MCP install page.

  5. Click the Install button in VS Code and Login with your account from the tenant above.

  6. For GitHub Copilot CLI, type /mcp add and follow the configuration: GitHub Copilot CLI Configuration

Learn more about Grant-EntraBetaMCPServerPermission.

If you have any issue on any of the above steps, please refer to the detailed installation instructions. You can try to execute the following to ensure Microsoft Graph PowerShell SDK Modules do not conflict with Microsoft.Entra.Beta:

Install-Module Uninstall-Graph
Uninstall-Graph -All

Microsoft Agent Platforms

ChatGPT

Go to Settings, Apps, Create App, and fill the dialog:
ChatGPT Configuration Put the App ID of the Registered app in the red box.

Claude

Go to Customize, Connectors, Click "+", Add Custom Connector, and fill the dialog:
Claude Configuration Put the App ID of the Registered app in the red box.

Authorization and permissions

The MCP Server for Enterprise uses Microsoft Graph API to access data in your Microsoft Entra tenant using delegated permissions only, and provides a reduced set of permissions exposed by Microsoft Graph.
Use the following cmdlet to list the permissions provided by the MCP Server for Enterprise:

(Get-EntraBetaServicePrincipal -Property "PublishedPermissionScopes" -Filter "AppId eq 'e8c77dc2-69b3-43f4-bc51-3213c9d915b4'").PublishedPermissionScopes | Where-Object { $_.IsEnabled -eq $true -and $_.AdditionalProperties["isPrivate"] -ne $true } | Select-Object Value, AdminConsentDisplayName | Sort-Object

If you'd like to use your own Registered Application, use the following cmdlets to to manage scopes granted to your MCP Client Application:

Grant-EntraBetaMCPServerPermission -ApplicationId "<MCP_Client_Application_Id>" -Scopes "<Scope1>", "<Scope2>", "<...>"
Revoke-EntraBetaMCPServerPermission -ApplicationId "<MCP_Client_Application_Id>" -Scopes "<Scope1>", "<Scope2>", "<...>"

Learn more: Manage MCP Server for Enterprise permissions

Advantages

  1. Remote MCP Server: Easy to configure, fully compliant, and highly reliable—deployed in the same regions as Microsoft Graph for optimal performance.
  2. IT Admins are in control: MCP clients need specific MCP.* scopes (mirroring Microsoft Graph Scopes) to be granted to access your tenant data.
  3. Simplified architecture: Works with just 3 tools instead of managing individual tools for every API operation.
  4. High-quality query generation: Generates accurate queries using over 500 real-world examples through RAG (Retrieval-Augmented Generation).
  5. Full auditability: Easily audit all MCP operations since they execute under the same App ID with a specific user agent.
  6. No extra license required: only existing Microsoft Entra and Microsoft Graph API licenses applies.

Availability, Roadmap and feedback

The Microsoft MCP Server for Enterprise is available only in the public cloud (global service), with support for sovereign clouds planned for a future release.
We will continue expanding beyond the current Microsoft Entra scenarios, but M365 APIs will be covered by Agent 365.
Support for write operations is planned for a future release.
Please share suggestions or issues through our feedback form: Submit feedback.

Licensing and usage

  • The MCP Server for Enterprise doesn't require extra cost or separate license.
  • You need the right licenses for the data you access (for example, Microsoft Entra ID Governance or Microsoft Entra ID P2 license for Privileged Identity Management (PIM) data).
  • Any request to this MCP server is limited to 100 requests per minute per user. Requests to microsoft_graph_get are also subject to Microsoft Graph Throttling limits.

Logs

To monitor usage, enable Microsoft Graph activity logs in your tenant. The system logs all API calls made through the MCP server.

Filter for MCP Server usage:

Use the Application (Client ID) of the Microsoft MCP Server for Enterprise: e8c77dc2-69b3-43f4-bc51-3213c9d915b4.

The following Kusto query retrieves these logs:

MicrosoftGraphActivityLogs
| where TimeGenerated >= ago(30d)
| where AppId == "e8c77dc2-69b3-43f4-bc51-3213c9d915b4"
| project RequestId, TimeGenerated, UserId, RequestMethod, RequestUri, ResponseStatusCode

Support and reference

For documentation, troubleshooting, and feedback, refer to the official Microsoft Learn documentation and support channels.

Security and compliance

All operations respect Microsoft Graph permissions and security policies. Ensure compliance with your organizational, regulatory, and contractual requirements when integrating the MCP Server.

No warranty/limitation of liability

This software is provided "as is" without warranties or conditions of any kind, either express or implied. Microsoft isn't liable for any damages that result from use, misuse, or misconfiguration of this software.

About

No description, website, or topics provided.

Resources

License

Code of conduct

Security policy

Stars

Watchers

Forks

Releases

No releases published

Packages

 
 
 

Contributors